冰楓論壇

 找回密碼
 立即註冊
搜索
查看: 1009|回覆: 0

[分享] 1.18大逃殺無後出草過檢測新思路源碼

  [複製鏈接]

1093

主題

2

好友

1281

積分

版主

Rank: 7Rank: 7Rank: 7

UID
172843
帖子
2007
主題
1093
精華
0
積分
1281
楓幣
26986
威望
1256
存款
0
贊助金額
0
推廣
0
GP
5436
閱讀權限
150
性別
保密
在線時間
492 小時
註冊時間
2016-12-18
最後登入
2021-10-18

積分勳章 發帖達人 2017年紀念勳章 太陽勳章 神手勳章 懶人勳章 幼兒勳章 性別(女) 性別(男) 音樂勳章 除蟲大隊 私服達人 Apple勳章 熱心助人 2017聖誕節紀念勳章 2018年紀念勳章 解說達人 論壇粉絲 2018端午節紀念勳章 版主勳章 中秋節紀念勳章 2018中秋節紀念勳章 2018萬聖節紀念勳章 2018聖誕節紀念勳章 2019年紀念勳章 2019端午節紀念勳章 2019中秋節紀念勳章 2019聖誕節紀念勳章 2020年紀念勳章 核心勳章 管理者 屁孩勳章 論壇支持王 2020端午節紀念勳章 2020中秋節紀念勳章 2020聖誕節紀念勳章 2021端午節紀念勳章 2021中秋節紀念勳章 2021年紀念勳章

發表於 2018-1-18 17:51:31 |顯示全部樓層

1.首先說下之前的,mklink和mklink /J就是利用軟鏈接將PAK文件(製作PAK方法論壇也有可以看一下)寫到PAKS文件夾中然後刪除,達到過檢測的目的簡單代碼如下:
paks=取文本註冊項 (4, “SOFTWARE\WOW6432Node\Valve\Steam\InstallPath”, ) + “\steamapps\common\PUBG\TslGame\Content\Paks\” ‘自動獲取不到可以利用’


ML=paks+ “TslGame-windowsNoEditor_paks”

創建目錄 (“C:\test”)‘可以創建任何目錄
YWJ=“C:\test”
order=“mklink /J ” + #引號 + ML + #引號 + “ ” + #引號 + YWJ+ #引號

寫到文件 (“C:\test\TslGame-WindowsNoEditor_cc.pak”, #去除草地)
寫到文件 (取運行目錄 () + “\quchucaodi.bat”, 到字節集 (order)) ' 生成軟連接bat命令
運行 (取運行目錄 () + “\quchucaodi.bat”, 真, ) ' 執行bat命令生成軟連接
延時 (300)
刪除文件 (取運行目錄 () + “\quchucaodi.bat”)


2.過檢測其實就是刪除軟鏈接



3.最新過檢測方法加載驅動或者調用360粉碎文件解除佔用 刪除寫入的源文件和軟鏈接代碼如下
.版本 2
.支持庫 spec


hwnd = LoadLibrary (取運行目錄 () + “\AntiRK.dll”)
.如果真 (hwnd < 1)
    信息框 (“載入模塊失敗!”, 0, , )
    返回 ()
.如果真結束
地址 = GetProcAddress (hwnd, “KillFile”)
.如果真 (地址 < 1)
    信息框 (“無法定位函數入口!”, 0, , )
    返回 ()
.如果真結束
文件 = “”
置入代碼({ 232, 0, 0, 0, 0, 88, 131, 232, 5, 80, 5, 170, 0, 0, 0, 80, 232, 5, 0, 0, 0, 233, 144 , 0, 0, 0, 139, 68, 36, 4, 141, 136, 120, 3, 0, 0, 59, 193, 115, 117, 186, 0, 0, 0, 232, 129, 56, 116 , 13, 104, 6, 117, 5, 57, 80, 4, 116, 18, 64, 59, 193, 114, 238, 139, 68, 36, 8, 199, 0, 233, 165, 0, 0 , 194, 8, 0, 139, 72, 253, 131, 192, 253, 129, 201, 255, 255, 0, 255, 131, 192, 4, 139, 209, 131, 192, 4, 129, 226 , 41, 101, 255, 3, 193, 233, 8, 137, 80, 248, 129, 225, 101, 255, 144, 0, 129, 201, 0, 0, 0, 144, 137, 72, 252 , 199, 0, 144, 144, 144, 144, 131, 192, 4, 199, 0, 144, 144, 144, 144, 102, 199, 64, 4, 144, 144, 139, 68, 36, 8 , 199, 0, 233, 165, 0, 0, 194, 8, 0, 139, 76, 36, 8, 199, 1, 233, 165, 0, 0, 194, 8, 0 }) ' 更改函數調用約定,必須的,否則堆棧錯誤
輸出調試文本 (call (地址, 取變量數據地址 (文件), 0, 0))

4.如果是玩家大可以用360粉碎文件粉碎或者其他粉碎機粉碎親測不會25C


5.國服就要上線,都是開源的東西 希望不要再收費了!


6.本人不才,寫的不好大神勿噴,小白可以學習學習!

感謝大家一直以來對PUBG的包容與支持!


源碼下載地址
155812xt9mm7btt7mty9oi.png

155814d0ni9n6csnpmirmm.png

155817ab24eap33zifw33w.png

155818p3id43i4nbsqntd4.png

161035mjexgxa8qzj3thkq.png

161036t8yenzz5jenfe5c8.png

161038gwpwepke0eehaezb.png




複製連結並發給好友,以賺取推廣點數
簡單兩步驟,註冊、分享網址,即可獲得獎勵! 一起推廣文章換商品、賺$$
您需要登入後才可以回帖 登入 | 立即註冊

正在連接伺服器...
打開冰楓聊天室
廣告刊登意見回饋關於我們職位招聘本站規範DMCA隱私權政策

Copyright © 2011-2021 冰楓論壇, All rights reserved

免責聲明:本網站是以即時上載留言的方式運作,本站對所有留言的真實性、完整性及立場等,不負任何法律責任。

而一切留言之言論只代表留言者個人意見,並非本網站之立場,用戶不應信賴內容,並應自行判斷內容之真實性。

小黑屋|意見反饋|手機版|Archiver|冰楓論壇

GMT+8, 2021-10-18 15:24

APP Store下載 Play Store下載
回頂部